MSFS 2020 Support Update 03.09.2020

This topic contains 112 replies, has 41 voices, and was last updated by  davidmalus 1 day, 13 hours ago.

Viewing 15 posts - 1 through 15 (of 113 total)
  • Author
    Posts
  • #1695

    sbrunner
    Keymaster

    Update 03.09.2020

    General:
    MSFS 2020 is released and works with all Force Feedback devices from BRUNNER since version 1.7.14.0

    EDIT: WARNING!
    If you are using USB Rudder Pedals, IGNORE this section and see Workaround below!

    Features:
    All Features are working (For Autopilot Enable the checkbox “Dont set POS in AP mode”

    How to use it with different Brunner Hardware…

    For all devices
    Do not map the axis in MSFS 2020, they are transmitted and handled over CLS2Sim directly

    Autoconnect:
    You can Enable Auto Connect to the simulator in Connection Settings see also here
    https://cls2sim.brunner-innovation.swiss/SettingsForm.htm

    CLSE Yoke
    Remark: The CLS-E Yoke does not have an integrated USB Game controller
    1. Install vJoy Diver see here https://cls2sim.brunner-innovation.swiss/VirtualJoystick.htm (is only used for buttons mapped in simulator)
    2. Open File->Settings in CLS2Sim and select “Use MS Flight Simulator X / MSFS2020”
    3. Connect to the Yoke (over USB or Ethernet)
    4. Connect to the Simulator as soon it is started (Click on the Connect button on the right side of the main window.)

    CLSE MKII-Yoke
    1. vJoy is not needed
    2. Open File->Settings in CLS2Sim and select “Use MS Flight Simulator X / MSFS2020”
    3. Connect to the Yoke over USB
    4. Connect to the Simulator as soon it is started (Click on the Connect button on the right side of the main window.)

    CLSE NG Yoke
    1. vJoy is not needed
    2. Open File->Settings in CLS2Sim and select “Use MS Flight Simulator X / MSFS2020”
    3. Connect to the Yoke over USB
    4. Connect to the Simulator as soon it is started (Click on the Connect button on the right side of the main window.)

    CLSE Rudder
    1. vJoy is not needed
    2. Open File->Settings in CLS2Sim and select “Use MS Flight Simulator X / MSFS2020”
    3. Connect to the Yoke over USB
    4. Connect to the Simulator as soon it is started (Click on the Connect button on the right side of the main window.)

    CLSE Joystick
    1. vJoy is not needed
    2. Open File->Settings in CLS2Sim and select “Use MS Flight Simulator X / MSFS2020”
    3. Connect to the Yoke over USB
    4. Connect to the Simulator as soon it is started (Click on the Connect button on the right side of the main window.)

    Updates will be posted here

    Thanks

    Stefan Brunner

    EDIT:

    Workaround when using a Non-Brunner USB Rudder Pedal
    Bug: When using USB rudder Pedals of any kind. Moving the USB pedal does override the Pitch and Roll axes.
    Bug has been reported to Microsoft, fix is pending.

    If you are using USB Rudder Pedals, ignore the above instructions and do the following instead:

    Please note: This workaround disables AP functionality with the Brunner Controls.

    1a) In the connection settings of CLS2SIm, check the “Force map vJoy Axes to Pitch/Yaw/Roll/Coll…”
    1b) Also set the Simulation type to MFSX/MFS2020.

    2a) In the CLS2Sim profile manager, go to axis range settings and check both “Disable” checkboxes for Pitch and Roll.
    2b) In the trim tab check the “Use hardware trim” checkbox.
    2c) In the Autopilot tab, uncheck the “Enabled” checkboxes for Pitch and Roll.

    3a) In MFS2020: Go to the controls and map the elevator and aileron axes to vJoy.

    Now connect to the sim and you will have force feedback and rudder does not override the yoke.

    Regards
    Diego

    #1703

    mrscott
    Participant

    Thanks Stefan! Best descriptive outline on how to setup a Brunner Product. Well done! Hope to see you on the Alpha Forum soon.

    MrScott8569

    #1704

    wrap23
    Participant

    Stefan, Thank you very much for providing a post from the source…You!

    A sim without Brunner is like a day without sunshine!

    Don

    #1705

    gandalf17
    Participant

    Thank you for the information,

    for the CLS-E Yoke with CLS2Sim v4.25.8 you mean “Emulate USB HID Joystick”? The option “Emulate USB MS Flight Simulator X” I don’t have. And with these setting I have no FFB.

    Is this correct?

    Martin

    Attachments:
    You must be logged in to view attached files.
    #1707

    sbrunner
    Keymaster

    Hi

    Sorry missprint it is “Use MS Flight Simulator X”

    Stefan Brunner

    #1708

    gandalf17
    Participant

    Thanks, and there is my problem.

    I’ve installed the MSFX plugin and the vJoy driver. In FS2020 under vjoy device there is no movement. With “Emulate USB HID Joystick” it works”.

    Martin Bauer

    Attachments:
    You must be logged in to view attached files.
    #1713

    sbrunner
    Keymaster

    Hi
    Read: 3. Select checkbox “Force map vJoy Axes….” (possible from CLS2Sim v4.26.2, beginning march update)
    You still have older Version
    open a ticket i can send you a link for newest

    Regards

    Stefan Brunner

    #1714

    sbrunner
    Keymaster

    Hi all
    Update 29.02.2020
    We have noticed, some mixed up with the USB mapping and transmitted axis data.
    (Pitch, Roll, and Yaw axis are jumping)
    Disable the connected axis in Profil manager
    see above
    Regards
    Stefan Brunner

    #1736

    ralingsmurf
    Participant

    hello and thanks to all the team for the great works 🙂
    long time without checking the forum…

    i’m glad to see there is a lot going on for fs 2020

    see you on the Alpha forum i am under the same name

    if you need specific test to do feel free to ask

    take care and stay safe

    Ralingsmurf

    #1743

    mrscott
    Participant

    Stefan,
    Would you be so kind and create a Step-by-Step installation by product like above for X-Plane and DCS? In the prior version I only had to connect my Rudder to the MKII via Ethernet and the MKII to the PC via USB. in v4.26.3 vJoy is no longer needed but I am required to connect both units to the PC USB and connect the two via Ethernet cable in order for both to work. In the Settings, USB HID device which should be chosen? I have both the MKII and the Rudder Peddles available and you cannot choose both. Lastly, and again in previous versions, I did not have calibrate or map keybinds inside x-plane. Now it seems like I have to set them up which again, seems counter intuitive to previous versions. So, please, post a comprehensive list of instructions for each product noting all the steps required to get the maximum benefit from your hardware. If X-PLANE and DCS are different from MSFS2020 then all the more reason we need your help to get it right. I use ALL THREE programs and want to get them configured correctly for each Sim. Thank you.

    #1877

    webmaximus
    Participant

    Reading the steps outlined above for using a CLS-E yoke with MSFS2020, I assume I also need to run the MSFX plugin installer even when this step isn’t mentioned?

    #1881

    akoudijs
    Participant

    When I click Connect the sim freezes and when I disconnect the sim resumes any solution?

    #1882

    vickeblomberg
    Participant

    I get the same issue, the sim freezes when I connect to it and resumes when I disconnect. It used to work on the MSFS2020 Alpha/Beta but doesn’t work on the release version.

    #1883

    Diego Bürgin
    Keymaster

    Hi everyone

    Problem with launch version is confirmed.
    Sorry for the inconvenience.
    We’re working on it and will release a new version in the next few days.
    I will notify you on this post also.

    Regards
    Diego

    #1884

    Diego Bürgin
    Keymaster

    Hi everyone

    I’ve isolated the problem. Yes it’s communication.
    Unfortunately it’s a problem from Asobo/Microsoft’s side, nothing we can fix.
    There are problems with the Microsoft API, specifically with the following API commands:
    SimConnect_TransmitClientEvent
    SimConnect_SetDataOnSimObject
    SimConnect_RequestDataOnSimObject
    SimConnect_RequestSystemState

    We use those for pretty much everything.

    I have submitted a bug report and will be getting in contact with folks over there to see if we can speed this up.
    As we are not the only ones having that problem, I am confident that the folks over at MS will have a fix shortly.

    In the meantime the only workaround is to use USB mode.
    So no force feedback. Sorry.

    I’ll keep you posted.

    EDIT:
    Clarification: The problem only happens in the launch version.
    The last ALPHA version (1.6.13.0) still works.

    Regards
    Diego

Viewing 15 posts - 1 through 15 (of 113 total)

You must be logged in to reply to this topic.

BRUNNER ELEKTRONIK AG

Industriestrasse 27
CH-8335 Hittnau

tel +41 (0)44 953 1010
fax +41 (0)44 953 1019

info(at)brunner-innovation.swiss

Help-Desk