CLS2Sim "Could not connect to Simulation": Annoying issue!

BRUNNER Forum Forums Software CLS2SIM Software CLS2Sim "Could not connect to Simulation": Annoying issue!

This topic contains 15 replies, has 4 voices, and was last updated by  yoveldelrio 9 months, 1 week ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #893

    yoveldelrio
    Participant

    Hi everyone,

    I recently purchased and received a new CLS-E NG Yoke. I must say the yoke is quite impressive, and using it makes the simulator feel like a real aircraft.

    However, I have ran into an annoying issue when attempting to connect the yoke to Prepar3D v4 using the CLS2Sim program.

    When I first start my computer and run P3D, CLS2Sim works fine, and allows my yoke to connect to P3D v4. I then go on to use P3D and the yoke works excellently.

    However, when I quit and close the P3D program, and later attempt to connect CLS2Sim to P3D, I see an error message which says, “Could not connect to Simulation.”

    Why is this?? As far as I can tell, P3D has fully closed. CLS2Sim is up to date, and has “Use LM Prepar3D” under settings selected. The only way I can resolve this is by resetting the computer. But I do not want to reset the computer every time I use the yoke with P3D.

    Any help on this matter would be much appreciated. Thanks!

    #895

    vp49p3
    Participant

    yoveldelrio

    I think each time you have to close the CLS2sim program besides closing P3D. I had the same problem as you. If I didn’t close CLS2sim, when I started P3D again, CLS2sim wouldn’t start.

    Question for you. I keep getting a message that says I am using unregistered hardware and that CLS2Sim will close in 10 minutes, which it does, and then tells me to purchase a license. I purchased my items directly from Brunner, so I can’t figure out why I keep getting the message. Anything you know to do?

    Thanks, Jay

    #897

    yoveldelrio
    Participant

    Thank you! As far as I can tell, that seems to have resolved my issue. But I’ll report back if it reemerges.

    As for your question, unfortunately I cannot say. I haven’t bumped into that issue, but it sounds quite odd. Sorry I can’t be of more help. Hopefully someone from Brunner can chime in.

    #898

    sbrunner
    Keymaster

    Hi all

    For anyone getting the message “hardware is not licensed” and CLS2Sim closing in 10 minutes please open a ticket in helpdesk

    Helpdesk

    We will provide a link with an update and a licensing tool

    Regards

    Stefan Brunner

    #900

    yoveldelrio
    Participant

    Looks like I may have spoke too soon regarding my issue. I’m still forced to restart my computer if I want to connect CLS2Sim to P3D v4.

    Any other options on how to resolve this?

    #903

    Diego Bürgin
    Keymaster

    Hi yoveldelrio

    I can’t reproduce the problem.

    Information I need:
    – Can you tell me step by step, what you do?
    – Do you have any other hardware connected? (Trim wheel etc)
    – I assume it happens regardless of what plane is loaded?
    If not what exact plane model are you using?
    – Also please tell me if any/what addons to P3D you have installed.

    Getting debug information:
    We just uploaded CLS2Sim 4.12.2 can you try it with that version?

    1. Go to the CLS2Sim installation folder and delete the file logfile.log
    2. Start CLS2Sim in Debug mode by running “CLS2Sim.exe -debug”.
    3. When you can’t connect again, close CLS2Sim after trying two/three times.
    4. Go to the CLS2Sim installation folder,
    make a zip file containing the folder “Settings” and the file “logfile.log”
    and upload the zip file here in the forum.

    Regards
    Diego

    #908

    yoveldelrio
    Participant

    Yes, I have the latest version of CLS2Sim (v4.12.2). The problem still persists. I deleted the logfile.log file… but I do not know how to start CLS2Sim in “Debug mode.” Could you explain? Is it a command prompt entry?

    In the meantime, I will explain what I’m doing step by step.

    1. I’ll start my computer (Windows 10)
    2. I’ll open CLS2Sim
    3. I’ll open Prepar3D v4.3
    4. When the Prepar3D scenario screen opens, I connect the hardware using CLS2Sim, initialize the hardware, and then connect the hardware to the simulation. All these steps are successful.
    5. I am then able to select any aircraft in Prepar3d (including 3rd party add ons), load any scenario, and use the Brunner yoke successfully by selecting one of my yoke profiles.
    6. When I’m finished using Prepar3D, I will exit the program, and ensure the program is terminated in my Task Manager.
    7. I will ensure CLS2Sim and all 3rd party Prepar3d add ons are terminated and exited.
    8. When I wish to use Prepar3d again, I will repeat steps 3 and 4, but will receive a “Could not connect to Simulation” message. The only way to remedy this is to restart my computer completely.

    I have and use the following:
    Windows 10
    CLS2Sim v4.12.2
    Prepar3D v4.3
    Active Sky for P3D v4
    REX Sky Force and REX Texture Direct
    FTX Central 3, which has installed various ORBX add ons, including FTX Global Base Pack and Vector
    Several 3d party add on aircraft (Including PMDG 737, Aerosoft Airbuses, CaptainSim 757, A2A C172, etc, etc)

    I also have and use SPAD.neXt, a program which I use to manage my Saitek hardware, including:

    Saitek Trim Wheel
    Saitek X52 Pro Joystick/Throttle
    Saitek Rudder Pedals
    Saitek Throttle Quadrant
    Saitek Multi Panel
    Saitek Switch panel
    Saitek FIP Panel

    All of the hardware functions properly in Prepar3D when I use Spad.neXt. Sometimes there are connection issues between CLS2Sim and my Saitek Trim Wheel, but this is remedied by reconnecting the yoke to CLS2Sim and restarting Spad.neXt. I do not think Spad.neXt is interfering. Even when I do not start it, I am unable to connect CLS2Sim to P3D.

    #909

    sbrunner
    Keymaster

    Hi yoveldelrio

    Upload a screenshot of your “Connection Settings” in CLS2Sim

    Regards

    Stefan Brunner

    #910

    yoveldelrio
    Participant

    Sure. I added an attachment.

    Attachments:
    You must be logged in to view attached files.
    #914

    sbrunner
    Keymaster

    Hi yoveldelrio

    Your connection settings looks ok

    Please do also what Diego has told you above and upload logfile.log

    ****************************************
    Getting debug information:
    We just uploaded CLS2Sim 4.12.2 can you try it with that version?

    1. Go to the CLS2Sim installation folder and delete the file logfile.log
    2. Start CLS2Sim in Debug mode by running “CLS2Sim.exe -debug”.
    3. When you can’t connect again, close CLS2Sim after trying two/three times.
    4. Go to the CLS2Sim installation folder,
    make a zip file containing the folder “Settings” and the file “logfile.log”
    and upload the zip file here in the forum.

    Regards
    Diego
    *******************************************

    Regards

    Stefan Brunner

    #915

    yoveldelrio
    Participant

    How do I start CLS2Sim in Debug mode?

    #917

    Diego Bürgin
    Keymaster

    1. Make a copy of the CLS2Sim shortcut on the desktop and rename it to “CLS2Sim debug mode”.
    2. Right-click on it and choose “Properties”
    3. In the Target textbox change
    “C:\Program Files (x86)\Brunner Elektronik AG\CLS2Sim\CLS2Sim.exe”
    to
    “C:\Program Files (x86)\Brunner Elektronik AG\CLS2Sim\CLS2Sim.exe” -debug
    4. Click OK

    Regards
    Diego

    #918

    yoveldelrio
    Participant

    Okay thanks. I gave the steps a try. Hopefully I did it correctly! I attached a zip file with the Settings folder and logfile file.

    Attachments:
    You must be logged in to view attached files.
    #920

    Diego Bürgin
    Keymaster

    Thanks.

    The log file tells me that CLS2Sim has no error.
    So we can say at least that all components had installed correctly.
    Maybe its a version incompatibility.

    At this point our only chance is a remote session.

    In CLS2Sim go to Help > Remote Support.
    Then send me the 9 digit id here.
    I’m UTC+2, in what time zone are you?

    Regards
    Diego

    #922

    yoveldelrio
    Participant

    Okay, thanks for the help. I’m US Eastern time zone.

    For now, it seems like this may be some sort of issue on my end. I think it has something to do with the Prepar3d process not ending properly when it closes, but I may be wrong.

    I’ll do some more troubleshooting, and if it doesn’t work out, I’ll arrange for a remote session sometime soon.

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.

BRUNNER ELEKTRONIK AG

Industriestrasse 27
CH-8335 Hittnau

tel +41 (0)44 953 1010
fax +41 (0)44 953 1019

info(at)brunner-innovation.swiss

Help-Desk