CLS2Sim UI stops working after using 'Profile Cloud'

BRUNNER Forum Forums Software CLS2SIM Software CLS2Sim UI stops working after using 'Profile Cloud'

This topic contains 14 replies, has 2 voices, and was last updated by  webmaximus 3 weeks, 2 days ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #2042

    webmaximus
    Participant

    One issue I’ve been mentioning a couple of times I’m sure in the past is how using Profile Cloud results in not being able to use CLS2Sim anymore unless you first end it via Task Manager and restart it. The UI “locks” in some way where all you get no matter where you click with the mouse is the Windows ‘Ding’ sound.

    Not often I use Profile Cloud these days but yesterday I had some 737 pilots over to check out my rig and they gave me some input to further adjust some settings to make it feel even more like the real thing. Now I thought I would share this by re-uploading my profile for the Zibo mod in X-Plane 11 and was quickly reminded of this bug in the CLS2Sim UI that has been there for pretty much as long as I can remember.

    Would you really nice if you could address this.

    #2059

    Diego Bürgin
    Keymaster

    Hi Webmaximus

    Diego here.
    I have to upload a release today, so you wont find a fix in the 4.27.10 version, but I will continue looking into this.

    I’ve tried many times again to trigger this bug, but have no success.
    I’ve introduced some artificial slowness and am able to bring CLS2Sim to freeze for about 5 seconds, but it recovers always.
    As you can get this to trigger 100% of the time, if you could do the following steps, that would help me greatly.

    Start CLS2Sim
    Open the Taskmanager
    Do a profile upload and when CLS2SIm freezes again, in the Taskmanager, right click on CLS2Sim and select “Create dump file”.
    A dialog will open showing you the path where the file has been saved.

    Please upload the file together with your CLS2Sim settings folder from the installation dir.
    Warning: the file can be very big (250MB) So you wont be able to upload it to the forum or ticket system.

    Regards
    Diego

    #2060

    webmaximus
    Participant

    Hello Diego and thanks for coming back on this one.

    Funny enough, I just tried this to get the dump file for you and what do you know…CLS2Sim didn’t freeze. The only thing I can think of different to the usual scenario is CLS2Sim at this time was already connected to X-Plane. Usually when I manage profiles in CLS2Sim, it’s not already connected to a simulator.

    No clue if that would make any difference but will come back to you as soon as I have a dump file for you.

    Cheers,

    Richard

    #2061

    Diego Bürgin
    Keymaster

    Hi Richard

    I did try while being connected to each of the sims and while being disconnected.
    What I observed is, the delay increases slightly if connected and also increases with the number of profiles you have.

    I have to switch to other issues now, but this stays on my list and if you have a dump file for me in the future, I will continue on this.
    In the meantime I wish you good flying.

    Have a pleasant day and until next time!

    Diego

    #2064

    webmaximus
    Participant

    Thanks Diego, will let you know if/when I see this next time.

    Wishing you a great day and weekend ahead as well!

    #2065

    webmaximus
    Participant

    Gave it another go with only CLS2Sim running without any sim connection and that triggered the issue straight away.

    I’ve uploaded the .DMP file to my Google Drive. You should be able to grab the file by using the link below. Please let me know once you have it and I’ll delete the file.

    https://drive.google.com/open?id=17QvP5w-1s08VAXZufn8XZSyU_8JfRU6y

    Richard

    #2066

    Diego Bürgin
    Keymaster

    Thanks for the file.
    I used it to make one iteration and have put it in a special build of the new release here:
    https://drive.google.com/file/d/1Hm1w26Z0jAbFtwYtlyNCcnVOgtORNLe_/view?usp=sharing

    We will have to repeat that with this one, so I can get further info.

    Diego

    #2067

    webmaximus
    Participant

    Got it.

    Will give it a go when I get home.

    #2072

    webmaximus
    Participant

    Below you’ll find a new .DMP file after experiencing the same issue using the beta version linked in your last post.

    https://drive.google.com/open?id=1ESjG3IPRJoLGGf2_ku53Qf52LsoOzKFZ

    Again, let me know once you’ve downloaded the file.

    #2073

    Diego Bürgin
    Keymaster

    I’ve downloaded it.

    #2074

    webmaximus
    Participant

    Thanks

    #2075

    Diego Bürgin
    Keymaster

    Thank you for your help.

    I’ve prepared another iteration:
    https://drive.google.com/file/d/13CJJK_m7jB0h7G9cwYSSUJweN-4ykgK0/view?usp=sharing

    Fingers crossed

    #2076

    webmaximus
    Participant

    Thank you Diego for looking into this long-standing issue and I’m happy to report, using the latest build linked in your last post, I was able to upload a profile without CLS2Sim hanging after doing that.

    I’ve also tried this new build out with the Zibo mod (3.43.18) and all seems OK.

    #2077

    Diego Bürgin
    Keymaster

    Thanks, happy to hear that!
    One more bug crossed of the list.
    I’ll put the changes into the next release.

    #2078

    webmaximus
    Participant

    Always nice being able to check bugs off a list 🙂

    Thanks again Diego and enjoy the rest of the afternoon!

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.

BRUNNER ELEKTRONIK AG

Industriestrasse 27
CH-8335 Hittnau

tel +41 (0)44 953 1010
fax +41 (0)44 953 1019

info(at)brunner-innovation.swiss

Help-Desk