MSFS Just Flight Arrow – Issue with notchy/sticky aileron control?

BRUNNER Forum Forums Products CLS-E Joystick MSFS Just Flight Arrow – Issue with notchy/sticky aileron control?

This topic contains 5 replies, has 3 voices, and was last updated by  jake 4 months, 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2439

    moespeeds
    Participant

    Anyone here using MSFS at all? I have a really strange problem. Got the Just Flight Piper Arrow and have been flying it for 2 weeks with no problems at all. Flew it yesterday, no problem. Today, I start up MSFS and the ailerons feel “notchy” or sticky. In the air, it rolls all over the place. I tried different profiles, same thing. If I hit escape/pause, the stick smooths out and it goes away, but comes right back when I get in the aircraft. If I try another aircraft, no problem, everything is fine. Tried turning off all the stick shaker effects, etc. Same problem, only with the arrow aircraft, no matter what profile I use.
    Elevator and rudder are fine. Only the ailerons have an issue. Tried all the usual reboot, updated the a/c, plugged/unplugged the hardware. I’m not sure how to troubleshoot this, as it worked fine yesterday, and nothing changed between now and then.

    CLS-E Stick/rudder

    #2441

    johnrutoski
    Participant

    Try creating a new profile in the Brunner CLS software. Make sure it’s new and not a copy of the original one you are using now. Sometimes the software can get corrupted so starting with a new profile will correct it.

    JR

    #2442

    moespeeds
    Participant

    New profile as in aircraft profile? I tried multiple profiles, as well as starting over with a “blank” profile, no joy.

    Again, this only affects the JF Arrow. All other aircraft work normally.

    #2443

    moespeeds
    Participant

    I did some more testing, it seems to be related to the Arrow autopilot. If I shut off the master switch in the aircraft, it works normally. It’s only when I power it up. I’ve verified that the autopilot is NOT on.

    See these videos:

    #2446

    moespeeds
    Participant

    Ok problem solved! The issue was that Oculus Home was opening with Steam VR, I had installed it for my Quest 2. I actually use a Pimax 8kx though. So for whatever reason, if Oculus Home opened with Steam VR, it would screw up the joystick. I uninstalled Oculus Home, and the problem is fixed.

    #2453

    jake
    Participant

    Hey Guys,

    I have a different problem with the JF Arrow III. Occasionally I run out of elevator when flaring for TD. When it happens I experience a big bounce.

    Not every flight, but it is annoying when it happens. I am using the default profile. If any of you guys have a profile that works, please upload it so those of us with no computer skills can use it.

    As a former owner of a Warrior II, this plane flies more like a real Piper. And it has become my favorite GA aircraft. Thanks for any help/suggestions!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

BRUNNER ELEKTRONIK AG

Industriestrasse 27
CH-8335 Hittnau

tel +41 (0)44 953 1010
fax +41 (0)44 953 1019

info(at)brunner-innovation.swiss

Help-Desk