XPlane10Connector for X-Plane 12?

BRUNNER Forum Forums Software CLS2SIM Software XPlane10Connector for X-Plane 12?

This topic contains 6 replies, has 3 voices, and was last updated by  racklefratz 2 months, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #2923


    Now that X-Plane 12 is out, I’ve been trying to get my CLSE MKII Yoke (USB) to work with it. It does not – CLS2Sim v5.41 update rate is unusably low – around 10 updates/sec, and CLS2Sim loses connection with X-Plane often. This situation essentially renders the yoke unusable in X-Plane 12. In comparison, I see an update rate of 66 updates/sec in P3D v5.3 with no disconnect issues whatsoever.

    In my X-Plane 12 Plugins folder, CLS2Sim has installed “XPlane10Connector” there. Seems strange to me that the CLS2Sim X-Plane plugin has not been updated since X-Plane 10 was released. Can that be the reason for the abysmally slow update rate and disconnect issues with X-Plane v12 now? I have tried uninstalling/reinstalling both CLS2Sim and the X-Plane plugin provided multiple times with no improvements.



    Can confirm this does not work on XP12. Really sad. Expensive hardware for flight simulation but does not support latest FAA Certified Flight simulator.



    Yep, agree. Brought this up months ago, and nobody cared. Appears that’s still the case.



    Back to Virpil and PFC pedals.



    One might expect that, given the investment involved, our FFB hardware would be kept up-to-date functionally to work with whatever simulation software versions are current. Sadly, it appears that we can’t expect that to happen. The potential’s there, hardware wise. But the software doesn’t appear to be capable.

    It’s another situation where one pays your money, and one takes your chances.



    I agree that things need to be updated to conform to platform changes, but not working in XP-12? I’ve been using my yoke and rudders since day… let’s say “day twelve”, as in the beginning I had some problems. After an early update, I had no more problems – though not perfect. I still get an error when connecting due to a “turbulence dataref” not being found or something. It still works as before, though.

    After a recent update I get much much higher update rate – in the order of what was mentioned above here – 50-70. I’ve never had that before, and haven’t really felt that it was needed. As long as it has been stable and above, say, 15 or 20 it has been perfectly fine.

    Again, I’d love to see more interaction and updates, but it is not a fact that it positively doesn’t work for everyone. I’m happily wobbling around in my DHC-2 Beaver, complete with all the force I need. 🙂



    Recapping my experience with this, the issues I see are with CLS2Sim not being updated to work with XPlane.

    The very fact that the software installs “XPlane10Connector” is a red flag – it’s not XPlane 10 anymore. It’s as if we’re expected to believe that no CLS2Sim updates are necessary with later versions of XPlane, but we’re getting the dataref errors from within XPlane 12, and the CLS2Sim update rates are very low. It’s obvious no one’s minding the store.

    I read somewhere previously that Brunner is not an XPlane fan. Is there a connection somewhere? Just wondering.

    **I’m** actually not an XPlane fan either – Prepar3D functions well with my Brunner yoke, and I think the flight models are much more realistic, as a US licensed pilot with over 2,000 logged flight hours. But still….

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.


Industriestrasse 27
CH-8335 Hittnau

tel +41 (0)44 953 1010
fax +41 (0)44 953 1019